BladeOne php Parse error

Recommend this page to a friend!

      BladeOne  >  All threads  >  BladeOne php Parse error  >  (Un) Subscribe thread alerts  
Subject:BladeOne php Parse error
Summary:Failes with php ver5.3.27
Messages:2
Author:Gary Smith
Date:2016-07-08 20:04:44
 

  1. BladeOne php Parse error   Reply   Report abuse  
Picture of Gary Smith Gary Smith - 2016-07-08 20:04:44
The requirements states that BladeOne will work with php 5.3, but I get a Parse error with php 5.3.27 in BladeOne.php on line 60, where an array is declared differently from the arrays above line 60.

Hoping you can change to work with php 5.3+ because I cannot change the php veriopn on the system where I hope to use this..

Thanking you in advance.

  2. Re: BladeOne php Parse error   Reply   Report abuse  
Picture of Jorge Castro Jorge Castro - 2016-07-09 20:30:30 - In reply to message 1 from Gary Smith
Right now, it changed to traits, so its not compatible with php 5.3 (that its discontinued)

However, you can rename the traits to classes. There are only 1 class and 3 traits so its not more than a few lines.

 

For more information send a message to info at phpclasses dot org.