Convert PDF file to older version: Merge PDF files of different versions

Recommend this page to a friend!
  All requests RSS feed  >  Convert PDF file to older version  >  Request new recommendation  >  A request is featured when there is no good recommended package on the site when it is posted. Featured requests  >  No recommendations No recommendations  

Convert PDF file to older version

A request is featured when there is no good recommended package on the site when it is posted. Edit

by Ed Bossmeyer - 5 years ago (2015-01-16)

Merge PDF files of different versions

This request is clear and relevant.
This request is not clear or is not relevant.

+1

I am using a class (fpdf/fpdi) to merge multiple PDF files.

However, the PDF parser that it uses only supports PDF versions older than 1.4.

I have encountered situations where PDF versions higher 1.4 must be merged.

So, I need a class that can read a PDF and save it as version 1.4 or lower.

  • 2 Clarification requests
  • 2. by CPK Smithies - 5 years ago (2015-02-28) Reply

    Suggest you use the open-source pdftops and pstopdf utilities. pstopdf allows you to specify the PDF compatibility.

    • 1. by Manuel Lemos - 5 years ago (2015-01-22) Reply

      Good question. This is a difficult problem, as more recent PDF generators will tend to generate PDF complying with newer PDF versions.

      Maybe it is more feasible to generate to convert old PDF version documents to newer versions and merge them into a single document with the newest version.

      Ask clarification

      Recommend package
      : 
      : 
      For more information send a message to info at phpclasses dot org.